[Ubuntu] Solusi untuk Pesan Error apt-get: "is to be installed"

Ketika menginstal aplikasi di Ubuntu mungkin teman-teman pernah mengalami error dengan pesan seperti berikut:

"deluge-console : Depends: deluge-common (= 1.3.0-0ubuntu1) but 1.3.0-1~getdeb1 is to be installed"

Pesan tersebut muncul karena teman-teman telah menginstal versi yang lebih baru dari dependency aplikasi yang ingin diinstal. Untuk mengatasi masalah ini kalian harus melakukan downgrade versi agar dependency aplikasi yang ingin diinstal dapat terpenuhi.

Untuk melakukan "pemaksaan" versi bisa dilakukan dengan cara sebagai berikut:
Buka Terminal dan ketik:
sudo apt-get install deluge-common=1.3.0-0ubuntu1
Sesuaikan perintah di atas dengan nama dependency yang mengalami masalah (dalam contoh ini adalah "deluge-common") serta versi yang dibutuhkan (dalam contoh ini "1.3.0-0ubuntu1").

Semoga bermanfaat.

3 comments :

SlameTux mengatakan...

Alhamdulillah selama ini belum pernah mengalami hal seperti diatas... (^_^)

hok00age mengatakan...

@SlameTux: Sedia payung sebelum hujan :D

SlameTux mengatakan...

yuph bener...

Poskan Komentar